Jump to content

Welcome to ExtremeHW

Welcome to ExtremeHW, register to take part in our community, don't worry this is a simple FREE process that requires minimal information for you to signup.


Registered users can: 

  • Start new topics and reply to others.
  • Show off your PC using our Rig Creator feature.
  • Subscribe to topics and forums to get updates.
  • Get your own profile page to customize.
  • Send personal messages to other members.
  • Take advantage of site exclusive features.
  • Upgrade to Premium to unlock additional sites features.

How to fix a cluster f* permissions issue on root of d:\?


Recommended Posts

I was having issues where the owner of subcontainers was administrator and not system like the root directory was, being system as the owner.  Now I messed it up trying to fix it & cannot access the drive at all now.


How do I fix this?



I want everything that hits the D:\ drive to have the owner as SYSTEM & give Everyone Full Access simply put.



I fixed it sort of by changing the owner to my account name which is also the only user allowed full control of the whole drive.  I just don't want that.  I want the owner to be SYSTEM so it works on any system & also the only user to be Everyone.  Why can't I change the owner to SYSTEM & only user to Everyone?  It says Access is denied.


*Update 2*
Tried changing the owner to SYSTEM & changing user to Everyone & that simply does not work unless I did something wrong?


*Update 3*

Finally got it dialed in so I can at least access my files again.  I have the permissions setup as follows.  Although it's still not how I want it with SYSTEM as the owner & the only user is Everyone.  I don't know why it breaks everything if I set it up that way?  By the way corrupting the permissions first then using your username as the owner replaces all child object permission entries with inheritable permissions from D:\ object permissions.  Then apply that then ok and ok close the window then re-open the security properties then add Everyone to the users while clicking "Replace all child object permission entries with inheritable permission entries from this object".





Edited by HeyItsChris
Link to comment
Share on other sites

I keep getting access denied with these permissions on the network share of my D:\ using my Username.  Why?  How do I fix this?


*PS - I have local permission granted but not over the network, why?*



Edited by HeyItsChris
Link to comment
Share on other sites

The process of taking ownership so that you can edit xbox files is specific and annoying. It's best to find a youtube guide IMO. 


Hopefully this video will help: 


  • Thanks 3



CPU: 5800x
RAM: XMP 3600mhz CL16
GPU: 7900XT
SOUNDCARD: Sound Blaster Z 5.1 home theater
MONITOR: 4K 65 inch TV
Full Rig Info
Link to comment
Share on other sites

You had mentioned trying to access the drive over your network, and that you had changed security settings to achieve the right permissions.  However, I didn't see you mention if you altered the sharing permissions as well?  They are 2 separate sets of permissions.  Considering how deep into the security permissions you went, I'd assume you did....but never hurts to double check the basics. 🙂 


Otherwise, you've got me stumped.  Looks like Windows 11, and I haven't personally played with that.  Should be similar to 10, in the sense that you just make sure the security permissions are set correctly.  You can also use the "administrators" and "users" groups if you'd rather apply permissions by account type (specific users is also fine).  And from there, ensure the share permissions are also set how you want, and it "should" just work.  It doesn't always, but I do think you're on the right track anyway.

The only time I've ever absolutely needed to change ownership was with very specific issues like MS OneDrive having ownership and not allowing me to do things with my own folders, or doing a wipe / reformat on the machine but not my second drive.....and the drive still has permissions from an old install or something.

  • Thanks 1

Too much



CPU: AMD FX 8350 @ 3.0GHz, 1.55v
MOTHERBOARD: Asus Sabertooth 990FX R2.0
RAM: 2x8GB GSkill RipjawX DDR3-1866 @ 1600, 9-9-9-24-2T
PSU: n/a dead
GPU: Asus RX 580 8GB @ 1400 / 2050 CFX
OPTICAL: Asus Blu Ray Burner
Full Rig Info

Too much



CPU: AMD Opteron 180 @ 3.0GHz
RAM: 4x1GB Corsair XMS DDR400 @ 2.5-3-3-6
GPU: Sapphire HD5870
OPTICAL: DVDRW with Lightscribe
Full Rig Info

Too much



CPU: AMD Athlon 1100MHz
RAM: 2x256MB Corsair XMS DDR400 @ 133MHz / CAS2
PSU: Antec 350w
GPU: ATI Radeon 9800 PRO
SOUNDCARD: Creative Live! 5.1
OPTICAL 2: IOMagic 48x16x48 CDRW
Full Rig Info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

This Website may place and access certain Cookies on your computer. ExtremeHW uses Cookies to improve your experience of using the Website and to improve our range of products and services. ExtremeHW has carefully chosen these Cookies and has taken steps to ensure that your privacy is protected and respected at all times. All Cookies used by this Website are used in accordance with current UK and EU Cookie Law. For more information please see our Privacy Policy